use new List API names

Lists: pgsql-patches
From: Neil Conway <neilc(at)samurai(dot)com>
To: PostgreSQL-patches <pgsql-patches(at)postgresql(dot)org>
Subject: use new List API names
Date: 2004-05-30 12:05:46
Message-ID: 40B9CE1A.2090700@samurai.com
Views: Raw Message | Whole Thread | Download mbox | Resend email
Lists: pgsql-patches

This patch updates the remaining parts of the source tree to use the
new List API function names and disables the list compatibility API
by default. This patch compiles without warnings and passes the
regression tests.

This patch does not remove the usage of FastList; that should also
be done.

Barring any objections, I intend to apply this patch on Sunday
evening (PDT).

-Neil

Attachment Content-Type Size
list-rewrite-updates-15.patch.gz application/x-gzip 35.3 KB

From: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
To: Neil Conway <neilc(at)samurai(dot)com>
Cc: PostgreSQL-patches <pgsql-patches(at)postgresql(dot)org>
Subject: Re: use new List API names
Date: 2004-05-30 16:03:08
Message-ID: 15676.1085932988@sss.pgh.pa.us
Views: Raw Message | Whole Thread | Download mbox | Resend email
Lists: pgsql-patches

Neil Conway <neilc(at)samurai(dot)com> writes:
> This patch updates the remaining parts of the source tree to use the
> new List API function names and disables the list compatibility API
> by default. This patch compiles without warnings and passes the
> regression tests.

I thought llast() and length() were going away too?

> This patch does not remove the usage of FastList; that should also
> be done.

I can deal with that later ...

regards, tom lane


From: Neil Conway <neilc(at)samurai(dot)com>
To: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
Cc: PostgreSQL-patches <pgsql-patches(at)postgresql(dot)org>
Subject: Re: use new List API names
Date: 2004-05-30 20:09:33
Message-ID: 40BA3F7D.4090608@samurai.com
Views: Raw Message | Whole Thread | Download mbox | Resend email
Lists: pgsql-patches

Tom Lane wrote:
> I thought llast() and length() were going away too?

For llast(), I decided to keep it around: it is nicely symmetric
with linitial(), and it makes any code that actually needs the last
value in a list significantly more readable. Since it's a macro
there's no runtime cost.

I had thought about keeping length() around, but on second thought I
don't see why we ought to. I'll replace it with list_length() and
post an updated patch.

-Neil


From: Neil Conway <neilc(at)samurai(dot)com>
To: Neil Conway <neilc(at)samurai(dot)com>
Cc: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>, PostgreSQL-patches <pgsql-patches(at)postgresql(dot)org>
Subject: Re: use new List API names
Date: 2004-05-30 21:09:44
Message-ID: 40BA4D98.7030906@samurai.com
Views: Raw Message | Whole Thread | Download mbox | Resend email
Lists: pgsql-patches

Neil Conway wrote:
> I had thought about keeping length() around, but on second thought I
> don't see why we ought to. I'll replace it with list_length() and post
> an updated patch.

The revised patch is attached.

-Neil

Attachment Content-Type Size
list-rewrite-updates-17.patch.gz application/x-gzip 52.3 KB

From: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
To: Neil Conway <neilc(at)samurai(dot)com>
Cc: PostgreSQL-patches <pgsql-patches(at)postgresql(dot)org>
Subject: Re: use new List API names
Date: 2004-05-30 21:31:55
Message-ID: 27456.1085952715@sss.pgh.pa.us
Views: Raw Message | Whole Thread | Download mbox | Resend email
Lists: pgsql-patches

Neil Conway <neilc(at)samurai(dot)com> writes:
> Tom Lane wrote:
>> I thought llast() and length() were going away too?

> For llast(), I decided to keep it around: it is nicely symmetric
> with linitial(), and it makes any code that actually needs the last
> value in a list significantly more readable. Since it's a macro
> there's no runtime cost.

> I had thought about keeping length() around, but on second thought I
> don't see why we ought to. I'll replace it with list_length() and
> post an updated patch.

Okay, that works for me.

regards, tom lane