Re: [PATCH] Exorcise "zero-dimensional" arrays (Was: Re: Should array_length() Return NULL)

From: Brendan Jurd <direvus(at)gmail(dot)com>
To: "David E(dot) Wheeler" <david(at)justatheory(dot)com>
Cc: Merlin Moncure <mmoncure(at)gmail(dot)com>, Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>, Josh Berkus <josh(at)agliodbs(dot)com>, pgsql-hackers(at)postgresql(dot)org
Subject: Re: [PATCH] Exorcise "zero-dimensional" arrays (Was: Re: Should array_length() Return NULL)
Date: 2013-06-15 05:39:41
Message-ID: CADxJZo2PwAgMPQbTyk1VYx8KuWQ=u1s+tzyVaQvH+3n_4wOKqA@mail.gmail.com
Views: Raw Message | Whole Thread | Download mbox | Resend email
Thread:
Lists: pgsql-hackers

On 14 June 2013 03:53, David E. Wheeler <david(at)justatheory(dot)com> wrote:
> Similar things should have dissimilar names. I propose:
>
> <bikeshedding>
>
> Old | New
> --------------+--------------
> array_dims | array_desc

array_bounds?

> array_ndims | array_depth
> array_length | array_size
> array_lower | array_start
> array_upper | array_finish
>
> The last two are meh, but it’s a place to start…

I think that even with the most dissimilar names we can come up with,
this is going to confuse people. But it is still better than doing
nothing.

I wonder whether, if we go in this direction, we could still use some
of the work I did on deprecating zero-D arrays. Let's say the old
functions keep doing what they do now, and we teach them to treat all
empty arrays the same way they currently treat zero-D arrays (return
NULL). The new functions treat zero-D arrays as though they were 1-D
empty with default bounds, and we add CARDINALITY per ArrayGetNItems.

This way, applications would not be broken by upgrading, and we'd be
giving people a way to opt-in to a better API.

Cheers,
BJ

In response to

Browse pgsql-hackers by date

  From Date Subject
Next Message Brendan Jurd 2013-06-15 06:08:56 Re: Hard to Use WAS: Hard limit on WAL space
Previous Message Craig Ringer 2013-06-15 04:43:10 Re: Hard to Use WAS: Hard limit on WAL space